Flashhilfe.de - Flash Community

Der Anfänger-Klassiker ... aber alle Lösungsvorschläge funktionieren nicht :( [Flash CS5]

 


AntwortenRegistrieren Seite1  

Mr.Egghead#1
Benutzerbild von Mr.Egghead
Beiträge: 1
Wohnort: berlin
Registriert: Jul 2011

21.07.2011, 13:25

EINLEITUNG:

Hallo alle beisammen!

Wie Ihr sehen könnt, bin ich ganz neu hier.
Und die Tatsache, dass ich mich hier angemeldet habe, ist ein eigentlich sehr schade und war ursprünglich nicht gewollt.

Denn ich für meinen Teill hasse nichts mehr als Menschen die sich bei Fragen einfach in einem Forum registrieren und dann dämliche Fragen stellen, die man mit einem simplen Google-Ausflug bereits hätte beantworten können. Oder wenn nicht das, dann zumindestens via "Hilfe & Themen-Suche".

Jedoch habe ich es mir beileibe nicht so einfach gemacht.
Seit nunmehr 7 Tagen google ich auf deutsch und englisch, finde zig Millionen Menschen mit dem gleichen Problem, mindestens genauso viele Vorschläge zur Lösung in Foren... und nichts davon funktioniert bei mir.
Ich bin in der vergangen Woche vom Flash-Nichtkenner zum Halb-Amateur herangewachsen.
Und war in meiner Verzweiflung sogar bereit, jemanden dafür zu bezahlen, dieses Problem von mir zu lösen. Jedoch ist sämtlichen professionellen Flashern der Auftrag zu klein, so dass alle ablehnen.

Und so bin ich nun hier gelandet.


DAS PROBLEM:

Wie eingangs erwähnt... es ist ein absoluter Klassiker.
Ich (eine absolute Programmier-Null) kaufe mir bei einem englischsprachigen Anbieter ein XML-Flash-Template.
Ich fuchse mich rein, alles klappt soweit ganz fantastisch.

Das einzige was nicht funktioniert ist, dass die deutschen Sonderzeichen und Umlaute nicht angezeigt werden. Jetzt schütteln hier alle wahrscheinlich den Kopf und sagen: das kann ja wohl nicht sein ernst sein!
Aber bevor Ihr mich an den virtuellen Pranger stellt, hier mein recherchiertes Wissen der letzten 7 Tage:

1) JA > in allen XMLs steht in der ersten Zeile <?xml version="1.0" encoding="utf-8"?> 

2) Ich habe zuerst Phase 5 benutzt, weiß nun aber, dass dieser Editor ohne Plugin nicht UTF-8-Kodierung unterstützt. Daher habe ich auf Notepad++ gewechselt.

3) JA > in der Index.php habe ich den Header ebenfalls wie folgt angepasst:

<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="de" lang="de">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>main</title> bla bla bla...

4) JA > manchmal muss man die Sonderzeichen im Flash-Film einbetten.
Auch das habe ich gemacht. Bei allen verwendeten Fonts wurden die Sonderzeichen "ÄäÜüÖöß" im Flash-Dokument jeweils eingebettet.

5) JA > ich weiß, dass nicht alle Fonts Sonderzeichen unterstützen.
Daher habe ich alle Fonts ins schnöde, aber diesbezüglich sichere,  Arial umgewandelt.

6) JA > ich habe auch den westeuropäischen Standard ISO-8859-1 ausprobiert. Gleiches Ergebnis, die Sonderzeichen werden nicht angezeigt.

7) JA > ich habe auch verschiedene Browser zur Ansicht benutzt. Sogar auf einem anderen Computer habe ich mir die Datei angeschaut. Immer noch nichts.

8) JA > auch von der Lösung ""system.useCodepage = true;" in den Hauptfilm" habe ich gelesen.
Aber keinen Plan wie das funktioniert.

Wie Ihr sehen könnt, habe ich wirklich alles erdenkliche probiert, gelernt und unternommen.
Und bin nun tatsächlich vollständig am verzweifeln :(((


Daher hier der flehende Aufruf:

Weiß irgendjemand da draussen auf dieser Welt, wie ich das dämliche Problem mit den Umlauten lösen kann ?????
Ich bin wirklich dankbar über jeden Vorschlag und jede Hilfe.

Wenn Ihr noch weitere Infos, Screenshots oder ähnliches braucht, sagt einfach bescheid!

Bis dahin drücke ich mir jetzt erst einmal selber die Daumen, dass dieses kaugummiartige Problem in Kürze ein glückliches Ende findet.


Tausend Dank an Euch !!!


Mr.Egghead
Werbung
Beiträge: 0
Registriert: Feb 2016


stealth_axg#2
Benutzerbild von stealth_axg
Beiträge: 172
Wohnort: Wiesbaden
Registriert: May 2009

21.07.2011, 20:41

:-D sehr geil geschrieben^^

Meine Vorschläge (Ka ob die funktionieren):
- HTML Umlaute verwenden (&Auml;&Uuml;etc.)
- Im XML den Tag "CDATA" nutzen BSP: <news><![CDATA['Jo']]></news>
Actionscript...O.o?.... Ist das ein neues Gewürz, was stinkt?!

API für C++ & Java
vindel#3
Benutzerbild von vindelFlashhilfe.de Moderator
Beiträge: 3000
Wohnort: Köln
Registriert: Oct 2007

23.07.2011, 13:11

Wenn HTML Umlaute verwendet werden, muss im Flash-Textfeld HTML aktiviert werden, damit diese richtig dargestellt werden.
public Weltformel(Problem){
      if (Problem gelöst) return Lösung;
      else Weltformel(kleiners Problem);
}
Revangel#4
Benutzerbild von Revangel
Beiträge: 16
Registriert: Apr 2011

03.08.2011, 12:00

so macht man es in php


mysql_query('set character set utf8');
Werbung
Beiträge: 0
Registriert: Feb 2016



AntwortenRegistrieren Seite1  

Schnellantwort

Du musst registriert sein, um diese Funktion nutzen zu können.

 
Ähnliche Beiträge zum Thema
Partner Webseiten: art-and-law.de  Mediengestalter.info   php-resource.de   phpforum.de   phpwelt.de   Pixelio.de   Scubacube.de  
Haftungsausschluss   Datenschutzerklärung   Hier Werben   Impressum
© 1999-2019 Sebastian Wichmann - Flashhilfe.de