Flashhilfe.de - Flash Community

FLVPlayback spielt flv vom Server nicht ab [Flash 10]

 


AntwortenRegistrieren Seite1  

pandochka#1
Benutzerbild von pandochka
Beiträge: 3
Registriert: May 2011

10.05.2011, 10:38

Hallo zusammen!
Ich versuche ein FLV Video vom Server mit FLVPlayback Komponente abzuspielen. Im Browser wird aber nur die Bühne angezeigt.
Wenn ich dasselbe Video lokal abspiele, funktioniert alles bestens. Wenn ich nur die URL im Browser eingebe, kommt auch sofort ein Pop-up zum Abspielen der FLV.

ActionScript:
1myPlayer.source = "http://beispielseite.net/servlet/MBibViewDataSaveFileServlet?blobid=131176";


ActionScript lädt die Videodatei auch scheinbar herunter, macht aber nichts mit ihr.
Habe schon ganz viele Sachen ausprobieren, doch hat bisher leider nichts geholfen. Hat jemand Ideen?


Danke im Voraus!
Anna
Geändert von pandochka am 10.05.11 um 11:07 Uhr
pandochka#2
Benutzerbild von pandochka
Beiträge: 3
Registriert: May 2011

Themenautor/in

10.05.2011, 11:07

Upd.: Mit NetStream und NetConnection wird das Video abgespielt. Liegt also wirklich an FLVPlayback....
pandochka#3
Benutzerbild von pandochka
Beiträge: 3
Registriert: May 2011

Themenautor/in

16.05.2011, 11:27

Habe endlich die Lösung gefunden!
Für alle, die dasselbe Problem haben:

FLVPlayback interpretiert query Strings in URLs als Verweis auf eine XML Liste.
Darum hat die URL "http://somewebsite.com/servlet/Servlet?id=131176" nicht funktioniert.
Hier eine perfekte Beschreibung, wie man das Problem umgeht:

Writing a Custom YouTube Player for a Google Gadget

AntwortenRegistrieren Seite1  

Schnellantwort

Du musst registriert sein, um diese Funktion nutzen zu können.

 
Ähnliche Beiträge zum Thema
Partner Webseiten: art-and-law.de  Mediengestalter.info   phpwelt.de   Scubacube.de  
Haftungsausschluss   Datenschutzerklärung   Impressum
© 1999-2021 Sebastian Wichmann - Flashhilfe.de