Flashhilfe.de - Flash Community

Ärger mit dem Sound [Flash 10]

 


AntwortenRegistrieren Seite1  

Tetenja#1
Benutzerbild von Tetenja
Beiträge: 69
Registriert: Apr 2013

23.12.2014, 12:24

Hallo zusammen !
Ich habe mir einige Uhren gebastelt, die ich mit einem Loader starte und mit einem Button durchschalte.Wenn alle Uhren durchgeschaltet sind geht alles wieder von vorne los.
Jetzt habe ich eine Uhr mit Sound ausgestattet und so wie das Script von dieser Uhr eingelesen ist, wird der Sound  auch bei allen anderen Uhren abgespielt.
Ich hab schon alles probiert um das Problem zu beheben, aber nichts klappt.
Ich hab selbst im Button vom Loader SoundMixer.stopAll (); eingegeben, was auch geht, aber wenn  die Bedingung wieder eintrifft spielt der Sound, obwohl die besagte Uhr gar-nicht dargestellt ist.
Dann habe ich es so versucht if (u == 0){ticksound.play()} und hab dann u in der nächsten Uhr  auf 1 gesetzt, auch ohne Erfolg.
Jetzt hab ich die Vermutung das Flash alle gelesenen Scripts im RAM belässt und den Sound einfach immer abspielt wenn die Bedingung war ist.

Kann man das so Programmieren das der Sound nur abgespielt wird wenn die entsprechende Uhr auch auf der Bühne liegt.Oder gibt es ein Befehl um den RAM zu löschen.

Vielleicht weiß jemand wie das überhaupt genau abläuft, weil wenn der Sound spielt, müssten ja auch alle anderen Bedingungen stimmen und die Grafiken der Uhr laufen im Hintergrund weiter.

Ich hoffe mir kann einer weiterhelfen.
rootriguez#2
Benutzerbild von rootriguez
Beiträge: 18
Wohnort: Berlin
Registriert: Sep 2008

18.02.2015, 15:38

Hi, hast du mal ein wenig Code ? Ohne ist es etwas schwierig...

AntwortenRegistrieren Seite1  

Schnellantwort

Du musst registriert sein, um diese Funktion nutzen zu können.

 
Ähnliche Beiträge zum Thema
Partner Webseiten: art-and-law.de  Mediengestalter.info   phpwelt.de   Scubacube.de  
Haftungsausschluss   Datenschutzerklärung   Impressum
© 1999-2020 Sebastian Wichmann - Flashhilfe.de