Flashhilfe.de - Flash Community

XML anbindung funktioniert nicht [Flash 9]

 


AntwortenRegistrieren Seite1  

Nardo#1
Benutzerbild von Nardo
Beiträge: 4
Registriert: Jun 2009

23.01.2011, 02:51

Hallo ..vorab muss ich sagen ich bin kein xml profi !

Ich habe eine Flashsite für facebook die ich in facebook nun integrieren will die flashsite hat einen xml mp3 player integriert dieser funzt auf html auf dem server sobald ich aber die swf anbinde an facebook geht alles ausser der mp3 player.


meine vermutung :

die xml anbindung in as2 lautet :

if(pathTo == "undefined" || pathTo == undefined)
      {
         pathTo = "player/";
      }
      
      
      if(_root.settingsPath == undefined || _root.settingsPath == "undefined")
      {
         settingsPath = pathTo + "xml/settings.xml";
      }
      else
      {
         settingsPath = pathTo + _root.settingsPath;
      }


kann es sein das es daran liegt das es nicht klappt weil facebook ja die xml nicht intern laden und da ne http://... verlinkung noch rein muss ??

und wenn ja wie mach ich das genau ?

Grüsse und vorab schonmal danke !!
RustyCake#2
Benutzerbild von RustyCake
Beiträge: 1776
Wohnort: Laimbach 6 1/2
Registriert: Nov 2002

23.01.2011, 11:34

Ist sehr wahrscheinlich so, liegt das ganze auf Deinem eigenen server?
Dann probieren mit vollständiger URIs referenzieren.
http://www.example.de/xml/settings.xml
Bitte keine Fragen, zu Flash per PM. Dazu ist das Forum da. Danke MFG_RustyCake!
"Wer tanzen will, muss erst gehen lernen"

AntwortenRegistrieren Seite1  

Schnellantwort

Du musst registriert sein, um diese Funktion nutzen zu können.

 
Ähnliche Beiträge zum Thema
Partner Webseiten: art-and-law.de  Mediengestalter.info   phpwelt.de   Scubacube.de  
Haftungsausschluss   Datenschutzerklärung   Impressum
© 1999-2020 Sebastian Wichmann - Flashhilfe.de